HFS knowledgebase

Below is the HFS knowledgebase of error messages and their solutions.

If you cannot find what you need to know, please contact the HFS team via hfs@it.ox.ac.uk.

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Summary This article will guide you resolving a warning message "The network path cannot be found" when attempting to perform a restore
Symptom After selecting which files/folders to restore and clicking Restore, the task list appears and states "Preparing". After a period of time a warning message states "The network path cannot be found". Clicking OK takes you back to the restore screen.
Cause A possible cause is that you are attempting to restore from an old machine to a new machine and have left the original location option set instead of selecting an alternative location - this is required as when using the original location the system uses the UNC path of the original files, such as \\oldnodename\c$\etc. Alternatively, perhaps your machine has been renamed between backup and restore: in this case too, the UNC paths would not match.
Resolution Please follow the instructions restoring data to a new machine..
Status You must select Following location when restoring data to a different machine, and then select a place to restore data to.
Applies To Spectrum Protect, Windows, Restoring
Summary This article will guide you resolving a "File Already Exists" message followed by repeated (if you select the overwrite option) "File is Read Only - Force Overwrite" messages when attempting to perform a restore
Symptom After selecting which files/folders to restore and clicking Restore, the task list appears and states "Transferring". A message may appear stating a "File Already Exists", if you select Overwrite you see a message that states "File is Read-Only - Force Overwrite", clicking the Overwrite just repeats the second message.
Cause Possible Cause - A possible cause of this issue is that you are attempting to restore files to a location that you do not have write access to.
Resolution Please restore the data, selecting an alternative location you do have write access to.
Status You must have write access to the folder to which you are restoring data to
Applies To Spectrum Protect, Windows, Restoring
Summary This article will guide you through resolving the error message "ANS7650E The user does not have sufficient privileges to execute IBM Spectrum Protect", followed by "ANS5179E Client is unable to continue. Exiting program", when you try to run Spectrum Protect.
Symptom When trying to run Spectrum Protect the error message "ANS7650E The user does not have sufficient privileges to execute IBM Spectrum Protect", is returned, followed by "ANS5179E Client is unable to continue. Exiting program." However, there is no problem with running scheduled backups, as reported in dsmsched.log and the HFS Backup Services Portal.
Cause This message is seen when Spectrum Protect is run by a user who does not have the relevant permissions.  To run Spectrum Protect on Windows, administrative or backup operator permissions are needed; administrative status is preferred, since we have seen reports of Spectrum Protect being slow to use by users logged in as backup operator.
Resolution

Run Spectrum Protect with administrator permissions.  You may have seen this error after selecting ‘Backup-Archive GUI.’ from the Windows apps list, or you may have run a shortcut to Spectrum Protect that is on your desktop.  Instead of left-clicking on such an item, right-click and select ‘Run as administrator’; a window will appear, asking, “Do you want to allow this app to make changes on your device? To continue, enter an admin user name and password.”  If you run Spectrum Protect from the HFS Hub then you will also be prompted for an administrator password in this way.

Another alternative is to log on to your machine using an account that has administrative access; then you will not be further prompted when running Spectrum Protect.

Applies To Spectrum Protect
Summary In some situations, the Spectrum Protect GUI client does not display mapped drives as available for backup even though the command line client will back them up fine.  This is to do with the way the drives have been mapped. Note that backups using the Spectrum Protect scheduler and command line client are unaffected
Symptom When attempting to back up files from a mapped network drive using the Spectrum Protect GUI, mapped drives are not displayed under Network.  The command line client backs up the mapped drives as expected.
Cause This is due to the way the drives have been mapped.  The drives need to be mapped by the computer administrator.
Resolution To access the mapped drives, run the Windows command prompt as administrator (right-click on the command prompt shortcut and choose Run as Administrator).  Then issue the command net use [drive letter:] \\servername\sharename.  The Spectrum Protect GUI should now be able to see the mapped drive.  This solution does not persist across reboots and so must be run before each manual GUI backup.
Applies To Spectrum Protect, Windows
Summary The backup of files stored in the cloud (e.g. OneDrive files) can fail silently, potentially leaving some files unprotected.  
Symptom

The Spectrum Protect error log (dsmerror.log) records a pair of messages which indicate that a cloud file could not be backed up.  These are of the following form:

ANS1228E Sending of object <filename and path> failed.

ANS4007E Error processing ‘<filename and path>’: access to the object is denied

A typical filename and path would include the machine name, drive and folder where the problem file is located.

You may therefore be unaware that some files are not being backed up.

 
Cause

Spectrum Protect cannot access a file because the file is not located on the local machine.

 
Resolution 

This can be worked around in one of the two following ways:

  1. Keep a copy of your cloud storage files on your local machine. In OneDrive, this involves right-clicking on your OneDrive folder and ensuring that the option 'Always keep on this device' is selected with a tick. Be careful to ensure you have enough space on your local machine for this process.
  2. Prevent Spectrum Protect from trying to back up your OneDrive folder by excluding it from backup: see further our instructions on excluding folders from your backup 
 
Applies To Spectrum Protect, Windows  
Summary This article will guide you through what to do when files expected to be available for restore by Spectrum Protect for Mac are not listed
Symptom Files expected to be available for restore by Spectrum Protect for Mac are not listed.
Cause You may not be able to see your restorable files on a Mac if you do not have permission to view them.
Resolution 1 The more common reason for this problem is that Spectrum Protect was run directly from the Spectrum Protect folder within Applications, rather than via the option Spectrum Protect Tools for Administrators. Spectrum Protect needs the Mac administrator password in order to allow you to see your files. Please ensure that you run Spectrum Protect via Spectrum Protect Tools for Administrators, which will oblige you to enter your Mac password and thus give you access to your files for restoral.
Resolution 2 If Resolution 1 did not enable you to see your files, then a small configuration change may be required. From macOS 10.15 (Catalina) onwards, Apple changed how programs access files. If you have reformatted your Mac and are attempting to restore your files, even if you have the same username as before, you therefore may not technically have permission to view backed-up files by default. To fix this problem you need to add the following text to configuration file dsm.opt: testflag guiskipdiraccesscheck. For the location of dsm.opt please see our FAQ item Where are the backup client software configuration and log files located?. If you require assistance in this matter, please contact the HFS Team on hfs@ox.ac.uk.
Status  
More Information  
Applies To Spectrum Protect
Summary

Spectrum Protect on macOS 10.14 (Mojave) is unable to back up files in some of your directories including Contacts, Desktop, Documents, Downloads, Photo Library, Mail, Messages and others unless you give it permission. Even then it does not work in all circumstances.

Information is available from IBM on this problem in their description at IT31110: ANS4007E AND I/O ERRORS SEEN WHEN BACKING UP MACOS MOJAVE 10.14.

Please note that this section applies only to users of Spectrum Protect who are running macOS Mojave (10.14).  For instructions for macOS Catalina (10.15) or higher with Spectrum Protect, please see the next Knowledgebase item

Symptom

When trying to back up the above directories, you receive the following error message: "ANS5057E Access to the specified file or directory is denied" or "ANS4007E Error processing <path>: Access to the object is denied".

Cause Apple's privacy and security settings for files and folders containing personal data introduced in macOS 10.14 (Mojave) prevent applications, including backup applications, from accessing data in some locations such as the desktop, documents etc. unless you explicitly give them permission. This causes difficulties using Spectrum Protect that have been resolved in later versions of macOS.
Resolution 1 The recommended resolution is to upgrade to a more recent version of macOS. You will still need to give Spectrum Protect permission to access your files (see the instructions in the next Knowledgebase item) but it will work properly. If you are unable to upgrade please see the following partial workarounds.
Resolution 2

On macOS 10.14 (Mojave), with the following changes in effect, certain folders can be backed up with manual backups only using Applications > Spectrum Protect > Spectrum Protect for Administrators, such as Documents, Downloads, Desktop, Movies and Music etc.; however, others such as Pictures, Calendar, Mail and others still cannot be backed up.  Please see resolution 3 below for instructions on how to back up the latter, if you need to do so.

1. Go to System Preferences > Security & Privacy Full Disk Access (unlocking the padlock if needed).
2. Add the following items to the list:

  1. Applications > IBM Spectrum Protect > IBM Spectrum Protect for Administrators
  2. Applications > IBM Spectrum Protect > IBM Spectrum Protect
  3. Applications Utilities > Terminal
  4. dsmagent
  5. dsmcad

If 'dsmagent' and/or 'dsmcad' are not on the list, then click on the '+' sign and navigate to '/Library/Application Support/tivoli/tsm/client/ba/bin' where you can find them.

All of the above items must be both present and ticked.

Resolution 3

It is possible to back up all files on a manual backup, if (1) the actions specified above in resolution 2 have been completed and (2) Spectrum Protect is run in a different way:

1. Go to Applications > Utilities.

2. Run Terminal.

3. Type in 'sudo dsmj' and press Enter.

4. You will be prompted for your the administrator password for your Mac.  When you type it in, no characters will appear on screen.  Type the password and press Enter.

5. Spectrum Protect will run.  You should now be able to select any files for backup.

Resolution 4

If you wish to use scheduled backups, then a further workaround is required, which involves stopping the usual backup scheduler and starting it in a different way.  Steps 4-8 need to be repeated each time that you start up your Mac.

  1. Go to Applications IBM Spectrum Protect > IBM Spectrum Protect for Administrators.
  2. Select Stop the Client Acceptor Daemon.
  3. Enter your Mac administrator password when prompted, and click OK.
  4. Go to Applications > Utilities.
  5. Run Terminal.
  6. Type in 'sudo dsmcad' and press Enter.
  7. You will be prompted for your the administrator password for your Mac.  When you type it in, no characters will appear on screen.  Type the password and press Enter.
  8. You may now close the Terminal window by clicking on the red circle at its top left corner.
Applies To Spectrum Protect, macOS
Summary Spectrum Protect is unable to back up files in some of your directories including Contacts, Desktop, Documents, Downloads, Photo Library, Mail, Messages and others unless you give it permission.
Symptom

When trying to back up the above directories, you receive the following error message: "ANS5057E Access to the specified file or directory is denied" or "ANS4007E Error processing <path>: Access to the object is denied".

Cause Apple's privacy and security settings for files and folders containing personal data in macOS 10.15 (Catalina)  and later prevent applications, including backup applications, from accessing data in some locations such as the desktop, documents etc. unless you explicitly give them permission.  Please note that the situation for Spectrum Protect on Mojave is different: on this, see the previous Knowledgebase item.
Resolution

1. Go to System Preferences > Security & Privacy Full Disk Access (unlocking the padlock if needed)
2. Add the following items to the list:

  1. Applications > IBM Spectrum Protect > IBM Spectrum Protect for Administrators
  2. Applications > IBM Spectrum Protect > IBM Spectrum Protect
  3. Applications Utilities > Terminal
  4. dsmagent
  5. dsmcad

If 'dsmagent' and/or 'dsmcad' are not on the list, then click on the '+' sign and navigate to '/Library/Application Support/tivoli/tsm/client/ba/bin' where you can find them.

All of the above items must be both present and ticked.

Applies To Spectrum Protect, macOS

 

Summary CrashPlan is unable to back up files in some of your directories including Contacts, Desktop, Documents, Downloads, Photo Library, Mail, Messages and others unless you give it permission.
Symptom Restricted areas of your disk(s), including external drives, cannot be selected for backup.  You will receive a message on running CrashPlan saying, “Files Not Backing Up On macOS”; note, however, that if you have previously dismissed this and said “Do not show this warning again”, the only symptom will be that files in these locations are not backed up.
Cause Apple's privacy and security settings for files and folders containing personal data in macOS 10.14 (Mojave) and later prevent applications, including backup applications, from accessing data in some locations such as the desktop, documents etc. unless you explicitly give them permission.
Resolution

1. Go to System Preferences > Security & Privacy Full Disk Access (unlock the padlock if needed)
2. Add the following item to the list:

  • Applications > CrashPlan

This item must be both present and ticked.

Applies To CrashPlan, macOS

 

Summary This article will guide you through resolving the error message "ANS2622S An invalid ID or password was submitted" when you try to run Spectrum Protect
Symptom When trying to run Spectrum Protect, the error message "ANS2622S An invalid ID or password was submitted" is returned.
Cause 1 Possible Cause – Spectrum Protect on your machine is configured with the wrong nodename.
Resolution 1 Check your Spectrum Protect nodename in the HFS Backup Services portal.  Then start the IBM Spectrum Protect Backup GUI and answer Yes to the error message that displays. At the Spectrum Protect main window, choose the Edit PreferencesGeneral tab.  Change the entry in the Nodename field to the nodename registered.  Click OK and restart Spectrum Protect.
Cause 2 Possible Cause – Spectrum Protect on your machine is configured to connect to the wrong Spectrum Protect server.
Resolution 2

Find the correct details for your configuration: go to the HFS Backup Services portalfind the relevant nodename from your list of nodes (if you have more than one node), and then click on the Configuration tab. There, click on the link for your main configuration file: this is dsm.opt for Windows, and dsm.sys for Mac and Linux.  Note the values for TcpServerAddress and TcpPort.

To check if you are connecting to the correct HFS Spectrum Protect server on your machine, start up Spectrum Protect and answer Yes to the error message that is displayed.  At the Spectrum Protect main window, choose the Edit > Client Preferences > Communication tab.  Ensure that the value in the Server Address field corresponds to the TcpServerAddress value which you noted down, and similarly that the value in the Server Port field corresponds to the TcpPort value.  If they do not, amend them to their correct values, click OK and restart Spectrum Protect.

Applies To Spectrum Protect
Summary This article will guide you through resolving the error message "ANS1357S Session rejected: Downlevel client code version" when you try to run Spectrum Protect.
Symptom When trying to run Spectrum Protect, the error message "ANS1357S Session rejected: Downlevel client code version" is returned.
Cause Possible Cause - You have accessed the HFS Spectrum Protect server from a machine using another machine's Nodename, and the more recently-used machine is running a more recent version of Spectrum Protect. Now when you try to connect to the  Spectrum Protect server, the session is rejected as being 'downlevel'. This is because the server records the client software level and strictly enforces the rule of disallowing lower-level client access.
Resolution If you have already encountered this problem, please contact hfs@ox.ac.uk for further help. To avoid this problem, if you need to access another node's backups, for example to restore vital data after a disk or system crash, use the  -virtualnodename option as documented in Restoring your data to another machine in the Command Line Interface instructions. Using this option does not cause the client level to be updated at the Spectrum Protect server with the current machine's client level, and is the supported method of cross-machine access to Spectrum Protect backups.  Please note that cross-platform restores between Windows, Mac and Linux are not supported.
Applies To Spectrum Protect
Summary

This article will guide you through resolving the error message "ANS1398E Initialization functions cannot open one of the IBM Spectrum Protect logs..." when you try to run Spectrum Protect.

Symptom When trying to run Spectrum Protect, the error message "ANS1398E Initialization functions cannot open one of the IBM Spectrum Protect logs..." is returned.
Cause 1 Possible Cause – You are attempting to run Spectrum Protect as a non-admin user.
Resolution 1 Make sure that you are running Spectrum Protect as a user who has administrator privileges.  In Ubuntu, precede your command to run Spectrum Protect with sudo
Cause 2 Possible Cause - The problem is related to the path of the log file that is subsequently listed at the end of the error message.  Typically this will be dsmerror.log, and the message will followed by 'errno=13, permission denied'.  Spectrum Protect requires that a writeable error log is available each time it is run.  If an error log (dsmerror.log) has been previously created/written by an admin user with permissions that prevent a non-admin user writing to it, then Spectrum Protect will fail to start when invoked by the non-admin user.
Resolution This is a file permissions problem and can be resolved or worked around in standard ways such as:
  • Change the permissions the admin user uses to create files and change the file permissions of the file.
  • Change the permission of the file only, to allow non-admin users to read and write to it.
  • Rename or delete the file and therefore allow a new one to be created by the non-admin user on starting the Spectrum Protect client.
Applies To Spectrum Protect
Summary This article will guide you through resolving the error messages "TCP/IP communications failure" or "TCP/IP invalid host name", followed by "Do you wish to continue for the purposes of local backupset restore?", when you try to run Spectrum Protect.
Symptom When trying to run Spectrum Protect, the error message "TCP/IP communications failure" or "TCP/IP invalid host name" is returned, followed by the question "Do you wish to continue for the purposes of local backupset restore?"
Cause 1 Possible Cause - this message will occur if there is a problem with your internet connection.
Resolution 1 Please check that you can browse web pages on the computer in question.
Cause 2 Possible Cause - You do not have a direct or VPN connection to the University network
Resolution 2 The HFS Spectrum Protect service can only be accessed from outside the University network using a VPN connection. This message will appear if you try to run Spectrum Protect over broadband without VPN running.
Cause 3 Possible cause - A local firewall is preventing the connection to the Spectrum Protect servers.
Resolution 3 Normally a firewall would not interfere with use of Spectrum Protect.  However, a local change in your department/college could result in you being unable to connect.  Please see your local IT if you think that this may be the case.
Applies To Spectrum Protect
Summary This article will guide you through what to do when your data restores run very slowly.
Symptom Data restores are running very slowly.
Cause If you are not using a wired university network connection, then your download speed might not be sufficiently fast for the amount of data that you wish to restore.
Resolution This should not be an issue on the wired university network; but, over a wireless or offsite connection, speeds will be limited. For a guide to how quickly you can restore data, use a speed test website to check your connection speed, and compare the results with the table of backup and restore speeds at our page on backup over VPN.
Applies To Spectrum Protect

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